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Introduction 
General 

Contact Center Modules (CCM) provides the user with the necessary tools to 
facilitate the management of call traffic. They are designed to provide a tightly 
integrated real time and historic reporting package and wallboard support for 
the eBusiness digital communications platform. The product consists of a set 
of fully integrated modules sharing a common database utilizing Interactive 
Directory and Database (IDD) technology. 
The suite of modules consists of the following applications: 
Call Center View (CCV):  
 Provides a management package for telephone based staff and supports 

any size Customer Facing Department (CFD) or contact center. To 
effectively control customer service levels, real time human resource 
management is essential and the Call Center View has been specially 
designed to manage the CFD’s or contact center’s most valuable and 
expensive asset – it's people. 

Call Center View Alarm Reporter:  
 Provides information (for each Call Center Profile) about alarms that have 

occurred within the contact center. The detailed alarm information for each 
directory number is presented in report format, which can then be printed. 

Wallboard Manager:  
 Real time information from the contact centre is essential to react to 

constantly changing telephone traffic levels and provide excellent customer 
service. Wallboards allow managers and staff to monitor the service being 
provided and respond immediately. Wallboards provide current information 
on the number of calls waiting, response times and service levels. 
Wallboard Manager provides the ability to drive Ferrograph physical 
wallboards and PC wallboards. 

PC Wallboard:  
 The PC Wallboard delivers traditional wall mounted wallboard functionality 

to the desktop but with the additional benefit of each PC Wallboard agent 
being able to configure and monitor a personalized view of the contact 
center. The PC Wallboard also enables agents to increase their 
productivity and maintain revenue levels with the added benefit of 
managing customer callback requests. 

Report Manager:  
 Provides in depth historical reporting on CFD or contact center activity. In 

addition to call information, the Report Manager also reports agent activity. 
This powerful package allows individual call records to be stored and 
reported upon months later.  

Workforce Management – Blue Pumpkin:  
 Workforce Management Interface allows integrated rostering, forecasting 

and scheduling systems to connect across the LAN to a comma separated 
variable (CSV) file containing a list of contact center related metrics. 
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Multimedia Module:  
 MultiMedia Module (MMM), is a customer contact software solutions that 

enables companies and departments to manage multimedia contacts into 
and out of the organization. MMM provides applications that manage Web 
Chat, E-mail and Web Call Back communications.  
For installation of MultiMedia Module, refer to the separate Installation 
Manual. 

Report Designer:  
 The Report Designer is a separate product that can be used in conjunction 

with Report Manager and is a software tool used for querying and 
reporting. It enables the user to create reports that contain data from their 
contact center database and schedule reports to be updated and printed.  
It is installed when Report Client is installed but requires a licence to 
operate.  

INDeX Taskbar: 
 Enforces the user rights and password protection as well as providing a 

single point of access to the Contact Center Modules. 
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Report Manager 
The Report Manager provides in depth historical reporting on Call Center 
activity. In addition to reporting on media type information the Report Manager 
allows reporting on agent activity enabling human resource management. The 
product is supplied with Corporate Document templates which may be 
parameterised by the user to create standard ‘management ready’ reports. 
With Report Manager, you can: 
– Access reports that contain data from the Archiver. 
– Organize and print your reports. 
– Refresh report data. 
– Schedule reports to be refreshed, printed, or save reports as HTML 

documents on web servers. 
Report Manager comprises of two elements - Report Server and Report 
Viewer. 

Report Server

Report 
Scheduler Archiver

Report Viewer

Report Manager

 

The Report Server stores all media type records (SMDR’s), along with agent 
status information records, into a Microsoft SQL database. Microsoft’s SQL is 
a resilient, open, industry standard architecture for data storage. Microsoft’s 
SQL incorporates automatic back-up routines and replication ensuring data is 
stored reliably. All media type records store detailed information about every 
transaction such as time of arrival, intended recipient, answering agent, CLI 
etc. In fact, the SMDR record contains up to 80 fields of data per transaction. 
Report Server comprises of two elements – Archiver and Report Scheduler 
Report Server allows up to 5 Report Viewers and providing users access to a 
central source of data across the network. 
Archiver obtains and accumulates the information from the INDeX system via 
the Delta Server. 
Report Scheduler offers scheduled or batch processing of documents. End 
users do not communicate directly with Report Scheduler. They communicate 
via the repository within the Report Viewer application. 
Report Viewer is a software tool to integrate reporting and analysis. It enables 
you to schedule Corporate Documents that display accurate, up-to-date data. 
Repository is a centralised set of data structures stored on a database. It 
enables the users to share resources in a controlled and secured environment. 
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Use of this Manual 
This manual covers the procedures of the Report Manager application.  It is 
divided into the following sections: 

Report Server 
• Archiver 
• Report Scheduler  
Report Viewer 
• Corporate Documents 
 

Microsoft Office Compatible 
Report Manager is a Microsoft Office compatible product, which means that its 
toolbars, menus, and accelerator keys are similar to those used by Microsoft 
Office.  If you are already using Office or an Office Compatible product, you 
will see that many tasks can be completed in a similar manner in Report 
Viewer.  These similarities make it easier for you to use the Office Compatible 
products together. 

• Office Compatible Features Supported by Report Viewer  
Report Viewer contains toolbars similar to the ones in Microsoft Office.  
You can print a document just by pressing the Print button on the Standard 
toolbar.  You can discover each button’s function by pointing to it with the 
mouse to activate a ToolTip that displays the button’s name. 
 

INDeX Taskbar 
INDeX Taskbar provides the ability to launch the INDeX CCM applications.  It 
also provides built in security through a logon procedure; i.e. you must log on 
tho th INDeX Taskbar before launcihing the INDeX CCM applications.  Further 
details on INDeX Taskbar are available form the INDeX Taskbar User Manual. 
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Report Server 
Archiver 

Archiver obtains and accumulates the information from the telephone system 
via the Delta Server. The Delta Server resides on a Server PC, the name of 
which will have been defined during installation (typically ARCHIVERSQL). 
Every time the Server PC is switched on, the Archiver is launched 
automatically. A telephone icon appears in the Windows Taskbar. If you close 
the Archiver screen, you can reopen it by double clicking on the telephone 
icon. Alternatively, if the Archiver is not running you can start it by: 
1. Ensure that the Delta server is running. 
2. Click the Start button on the Windows taskbar. 
3. Point to Programs and then to INDeX CCM. 
4. Click Archiver from the sub-menu. 
The information on the screen is as follows: 
• Status   - Indicates the status of the Archiver. 
• Started  - Indicates the date and time Archiver was launched. 
• Last Msg At  - Indicates the last message received from the Delta Server. 
• Received  - Indicates the number of messages received from the Delta 

Server during this session. 
• In Queue  - Indicates the number of messages waiting to be stored in the 

database. 
• Indexed  - Indicates the number of messages that have been indexed. 
• Rejected  - Indicates the number of messages that were rejected by the 

Archiver because of corruption or invalid message in the telephone system 
database. Rejected is incremented when an SMDR is corrupted owing to 
external factors (e.g. cable breakage, or data corruption in the database). 
This figure should never increment. If it does, it is advisable to check all 
cables, network setting, names in the database, etc. Occasionally SQL 
problems can also cause an increase in this number. If this occurs, check 
the System and/or SQL Events Log. 

• Database Server  - The name of the SQL server. 
• Delta Server   - The name of the delta server. 
• Metrics   - Indicates the number of SMDR messages received by the 

Archiver. 
• Activities  - Indicates the number of Agent activity messages received by 

the Archiver. This figure will be considerably higher than the Archiver 
Metrics figure. 

• Call Flow   - Indicates the number of Call Flow messages received by the 
Archiver. Call Flow metrics are only available when configured in Voice 
Mail.  

Note: To close the Archiver screen, from the File menu, select Close. To quit 
the Archiver application, from the File menu, select Stop and Exit. 
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Archiver Setup Options 
From the Archiver toolbar, Setup provides access to: 

• Log Events 
• Language 
• Change Delta Server 
• Change Database Server  
• Alerts  
 

Log Events 
This Setup option enables the Log Events feature to be switched on or off. 
This feature is for Technical Support Engineers use only and should only be 
enabled at the request of Technical Support personnel. 
 

Language 
This option enables you to change the language of the Archiver. To change 
the language, from the Setup menu point to Language and select the required 
language from the list of available languages.   
 

Connection to Delta Server 
To connect to a different Delta Server within the network: 
1. From Setup, select Change Delta Server. 
2. A screen will appear which indicates that the Archiver has located the 

available Delta Servers. If the required Delta Server is listed, select it and 
then click the Connect button. 

3. If the required Delta Server is not listed, click the Advanced button. 
4. Select one of the search options and then click the Search button. 
5. Select the required Delta Server and then click the Connect button.  
 

Connection to Database Server 
To connect to a different Database Server within the network: 
1. From the Setup menu, select Change Database Server. 
2. The connection details screen appears with the current server displayed. 
3. From the pulldown list, select a new Database Server from the list. 
4. As required, enter the Login identity and the Password.  
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Alerts 
When an error event occurs you can send an Email alert of the occurrence to 
your System/Network Administrator. To format the Email alert, from the Setup 
menu point to Alerts to display the following menu: 

 
Settings: 
 Minimum message interval:  This can be set in either hours or minutes 

and is the period between Alert Email transmissions 
 Error threshold:  This sets the number of error messages that can occur 

before an Alert Email is transmitted. 
The above two settings are not mutually exclusive. For example, if the 
Minimum message interval is set to 2hrs and the Error threshold is set to 3, 
then the following table shows when Alert Emails are sent: 

No. of Error 
Events 

When Alert 
Sent 

Reason 

1st Before 2hrs interval Yes 1st message always sent 

2nd Within 2hrs No Interval not exceeded, 
Threshold not reached 

2nd same as above 
but at different time 

same as above but at 
different time 

Yes Interval exceeded 

3rd Within 2hr Yes Interval not exceeded, but 
Threshold reached 

3rd same as above 
but at different time 

same as above but at 
different time 

Yes Both Interval and Threshold 
exceeded. 

 

Status: 
Provided that you have an email facility (e. g. Outlook), use this button to 
access your log on/off menu.  

Fields:  
 Recipients:  Either, click the button on the right hand side to access your 

Email contact list and select as required or enter the required Email 
address. 

 Subject:  Either, accept the default (Archiver Alert) or enter you own 
subject title.  

 Message: Either, accept the default message header (The following 
events have occurred) or enter you own header. The actual list of errors 
will appear after the header. 
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Archiver View Options 
From the Archiver toolbar, View provides access to: 

• Event Log 
• Refresh F5 
• Interval  
 

Event Log 
When the Archiver Log Events option on the Setup menu is selected, the 
Archiver writes connect, disconnect, rejected messages, etc. to a log file. The 
log file is stored as Archiver.log in the applications directory 

 
 

Refresh F5 
This option enables you to refresh (update the information displayed) of the 
Archiver Event log screen. 
To update information: 
1. From the View menu, select Refresh.  
 

Interval 
This option enables you to change the automatic refresh period (update the 
information displayed) of the Archiver Event log screen. 
To alter the interval at which the information is updated: 
1. From the View menu, select Interval. This option also enables you to 

select the interval at which the information is updated. The intervals are 0.5, 
1, 2, 5 and 30 seconds. The default is set to 1 second. 

2. Select the required interval.  
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Report Scheduler 
Overview 

The Report Scheduler integrates with the Report Manager to provide report 
clients the ability to schedule reports to run at chosen intervals. The Report 
Scheduler makes use of the Report Repository database to store scheduled 
reports and associated schedule details. It is, therefore, installed as part of the 
Report Manager installation. It is designed to put the call centre manager in 
control of their call centre.  
 

Starting Report Scheduler 
Every time the Server PC is switched on, the Report Scheduler is launched 
automatically. To amend the auto start facility, refer to "Preferences" on page 
15. 
If the Report Scheduler is not running you can start it by: 
1. Click the Start button on the Windows taskbar. 
2. Point to Programs then to INDeX CCM. 
3. Click Report Scheduler from the sub-menu.  
The Report Scheduler window lists the tasks sent for processing. For each 
task, the window displays such information as the document name. Status, 
owner, priority and submission date. 

Notes: 
1. If not logged on to your mailbox, you will be prompted to do so. 
2. If the Scheduler is not able to connect to the Database Server, you will be 

prompted to select a server. 
 

The Schedule List Screen 
The Taskbar Area 

The left side of the taskbar at the bottom of the screen displays the current 
state of the scheduler. Detailed below are the various states. 
Ready:  The scheduler is idle. 
Connecting:  An attempt to connect to the repository database is in progress. 
Not Connected:   The scheduler is not currently connected to the repository. 
This state is associated with a red warning triangle. 
Running:  A scheduled task is being executed.  
The middle of the taskbar shows the email login (provided that MAPI is 
available). The right side of the taskbar displays the date and time that the 
schedule was last refreshed. This value is taken from the SQL server and is 
formatted according to the language selected for the application. 
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The Schedule List Details Section 
The schedule list displays details of each scheduled task. The columns that 
can displayed are detailed below. 
Status: The status of a task: Waiting, Disabled, or Running. 
Title: The title of a report associated with a task. 
Description: This is a user-defined text, which can be up to 254 characters. If 

the user has not defined any description, this section will be blank. 
Owner: The profile name that created the task (usually Designer or Viewer 

names according to the language). 
PC Name: The name of the PC that was used to create the task. This field 

may be blank. 
PC Login: The Login used in the PC that was used to create the task. This 

field may be blank. 
Submitted: The date and time that a task was created. This information is 

taken from the PC that was used to create the task. 
Start/End Dates: These two columns display the dates that the task was run. 
Frequency: How often the task is to run i.e. Once, Daily, Monthly or Month 

Days. 
Day: The days(s) on which a task will run. This value is dependent on the 

Frequency selected. 
Time intervals: The time(s) at which a task will be run. Al times are rounded 

to the nearest minute. 
Distribution: A report associated with a task can be distributed to a printer, via 

email or sent to a folder on the PC. This feature permits the System 
Administrator to define which options the Report Clients can select from. 

Next Run: The date and time that a task will next be run. This value will be 
empty when the task has run for the last time before expiring. 

Last Run: The date and time that a task was last started running. This value 
will be empty until the task has been run once. 

Last Run End: The date and time that a task was last completed. This value 
will be empty until the task has been run once. 

Result: This value will be empty until the task has been run once. It can be 
either Successful or Failed.  

Note: All date and time values are displayed using the date and time formats 
according to the language for the application. Times are rounded to the 
nearest second unless otherwise specified. 
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Refresh/Run Pending 
Refresh    
Although the schedule list is automatically refreshed at regular intervals, 
clicking on the Refresh button (or pressing F5) allows you to manually refresh 
the data. You can also select the refresh option from the File menu. When the 
schedule refreshes, expired tasks are removed and any task created since the 
last refresh will be displayed. 

Run Pending . 
When the schedule is automatically refreshed, any pending tasks are run 
starting with the task that has been pending for the longest time. Pending tasks 
can be manually run by clicking the Run Pending button. You can also select 
the Run Pending Tasks option from the File menu.  
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Scheduler Setup Options 
From the Report Scheduler toolbar, Setup provides access to: 

• Language 
• Distribution 
• Preferences  
 

Language 
This option enables you to change the language of the Archiver. To change 
the language, from the Report Scheduler Setup menu point to Language and 
select the required language from the list of available languages. 
 

Distribution 
Reports associated with a task can be distributed via a printer, email or sent to 
defined folder on the PC. This Setup option allows the System Administrator to 
define which options the Report Clients can select from. 
To define the distribution options: 
1. From Report Scheduler Setup, point to Distribution and the Printers 

option menu is displayed. 
2. Click on Add and a list of available printers is displayed. 
3. Select the required printer. If further printers are required, repeat step 2. 
4. If you do not wish to print empty reports, untick print empty reports box. 
5. Click OK to finish. 
6. Select the Email option tab and click on Add. 
7. Your email Contact List will be displayed. Select required email address or 

add a  new address. 
8. Select (tick box) the required format of the message (business object 

Reports and or PDF). 
9. If further email address options are required, repeat step 7. 
10. As an option, you can enter, in the Subject Text and Message Text boxes, 

preset headings/messages for the subsequent email messages. 
11. If you do not wish to print empty reports, untick print empty reports box. 
12. Click OK to finish. 
13. Select the Export option tab and click on Add. 
14. From the Browse menu displayed, select from your PC, network, etc. the 

destination folder to which you wish Reports to be sent.  
15. Select (tick box) the required format of the message (business object 

Reports, PDF or HTML). 
16. If further folder address options are required, repeat step 14.  
17. If you do not wish to print empty reports, untick Print empty reports box. 
18. Click OK to finish. 
19. To delete a destination, from any of the Printers, Email or Export tabs, 

highlight the entry and simply click on Remove. 
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Preferences 
To set the preferences for Report Scheduler, from the Options menu select 
the Preferences and the General tab is displayed.  
Update Interval 
This area allows you to set the interval that the schedule list is automatically 
refreshed, pending any tasks that are running and the printers available to 
clients. The maximum interval for this setting is 20 minutes.  

Auto Start 
In this area you can set up whether the application runs when windows is 
started and if it is how it will run. If you select the option Run when windows 
starts the associated options become available. 

• Display normally causes the splash screen to be displayed and 
subsequently the schedule screen (pending a successful connection to the 
repository database). 

• Start Minimised causes the Display Splash screen option to become 
available. If Display Splash screen is not selected, the application will 
display the schedule screen minimised. Selecting Display Splash screen 
causes the splash screen to be displayed when the application starts and 
subsequently display the schedule screen minimised. 

Note: Database connection failure prompts will be displayed regardless of 
the options selected.  

 
When completed, select the Column preferences tab.  
Columns 
This tab enables control of the columns displayed in the schedule screen. 
Each column listed has an associated check box, which can be used to 
determine which columns are displayed and which are not. The position of a 
column can be changed by selecting it in the list and then using the up and 
down arrows to move it either up the listing or down the listing. The top of the 
list is the left most column shown in the Schedule screen. When a column is 
de-selected, the name is shown at the end of the listing. 
Note: The row number and the status column cannot be moved and cannot 

be hidden. 
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Editing Report Scheduler 
Report Scheduler Tasks can be edited in two ways. 
1. You can select a task and then chose an option from the Edit drop down 

menu. 
Or 
2. Right mouse click a task to view a pop-up menu. 
 The options in the pop-up menu are in a different order to those in the Edit 

menu. This is to minimise the possibility of unintended options being 
selected. The contents are the same in both menus except that the pop-up 
menu contains the 'cancel' option. The available options in these menus 
are as follows. 

Option Action 
Cancel Closes the pop-up menu. 

Disable/Enable Toggles whether the selected task is enabled. If 
disabled, the task does not run but at the times that the 
task would have run if it were enabled, the 'Next run 
Date' is re-evaluated. 

Run Now Runs the selected task immediately. This does not affect 
the existing values of the 'Next Run Date'. 

Delete Removes the selected task from the schedule. When 
selecting this option the confirmation prompt is displayed. 
The 'no' button is the default button so that if the return 
key is pressed the task will not be deleted. Tasks can 
also be deleted by selecting and then pressing the delete 
button. 

Properties This option displays the schedule properties for the 
selected task. 

Report Values This option permits the values of the VM Group 
(members), Breakdown range (time) and the Shift 
Begin/End (time) to be defined. 
To change any Value, highlight the entry and click on 
Values. 
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Report Scheduler File Options 
From the Report Scheduler toolbar, File provides access to: 

• Email - enables user to Log on/off 
• Import/Export 
• Refresh/Run pending  
• View History 
• Exit  
 

Import/Export 
Provides the ability to import/export both Schedules and Distribution 
Configurations from other locations.  
 

View History 
To view the history of tasks from the File Menu, select the View History 
option. 
The history screen displays details of up to the last 600 tasks run. The most 
recent date and time that the tasks were run will be at the top of the screen. All 
the columns available to the schedule screen are displayed in default order. 
Each line displays details of the task immediately after having been run. The 
success or failure of each task run can be reviewed along with the date and 
time that the task was run. 
If you click the Refresh button, the listing will be updated with any tasks that 
have been run since opening the screen. 
To clear the log file click on the button labeled Clear. A confirmation dialog will 
be displayed asking you to confirm that you wish to clear the log history. The 
'no' button is the default button so that if the return key is pressed the task will 
not be deleted. Tasks can also be deleted by selecting and then pressing the 
delete button on the keyboard. 
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Report Viewer 
General 

The Report Viewer is designed to put the Call Center Manager in control of 
their Call Center. With a set of graphical, color, and management ready report 
templates. It reduces Call Center management time by reducing the need to 
export data into other applications to run reports. 
The Report Viewer gives access to the data stored on the Report Server 
across the LAN. 
With the inclusion of Corporate Document templates, the Report Viewer has 
been designed with ease of use in mind. The user simply creates parameters 
for these reports in terms of agent groups, shift period, date range etc to 
generate the data they require. Date ranges available are today, yesterday, 
specific day, this week, last week, this month, last month or date range. These 
standard templates have been written to give the Call Center Supervisor a 
detailed understanding of Call Center activity, with reports ranging from agents 
activity, DDI, trunk, transferred calls, CLI, Voice Manager reports and call 
tracking reports. 
The Corporate Documents are available in the following categories: - 
Account Code, Agent, CLI, DDI, Outgoing Calls, System Summary, Transfer 
Calls, Trunk, Trunk Group, Voice Manager. 
 

Launching Report Viewer 
To start Report Viewer clicking on the Icon within the INDeX Taskbar or follow 
the steps below. 
1. Ensure that the Report Server is running, that you are logged onto the 

INDeX Taskbar, that the Database Server and the Delta Server are both 
running. 

2. Click the Start button on the Windows taskbar. 
3. Point to Programs and then to INDeX CCM. 
4. Click Report Viewer from the sub-menu. 
 
Notes:  
1. On the Report Viewer start-up screen, if you removed the tick in the 

Connect to Last Delta Server box, then when you restart the Report Viewer 
you will be prompted to search and connect to a Delta Server. 

2. If you receive prompts (error messages) for the Database and/or Delta 
Server connections, then repeat step 1 above.  
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Main Screen 
Descriptions of the toolbar buttons are displayed on-screen when the pointer 
pauses on them. The buttons on the toolbar are as follows: 

 – Open  
Opens an existing Report in a new window. 

 – Save  
Saves the current report in the name, file format and folder that you previously 
defined in the Save As dialog box. When you save a document for the first 
time, Report Viewer displays the Save As dialog box. If you want to change the 
name, location or file format, select Save As from the File menu. 

 – Print  
Controls how a document is printed. To print, you must first install and select a 
printer. Refer to your Windows documentation for more details. 

 – Print Preview   
Displays each page of a report as it will appear when printed. The status bar at 
the bottom of the screen shows the page number and the total number of 
pages in the report. 

 – Paste – Currently not supported. 

 – Undo/Redo – Currently not supported. 

 - Report Manager  
When a report is on screen this button is active. By clicking on the Report 
Manager button the map view of the report will be closed. 

 – Refresh  
Enables you to update the data in your report, so that you work with the latest 
data from the database. 

 – View Data  
Displays the Data Manager dialog box, which shows the contents of the data 
providers in the current Report. 

 – Zoom  
Controls how large or small a report appears on the screen. 

 - Schedule Report  
Allows you to submit a report for scheduled processing.  
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Managing Report Viewer 
Retrieve Documents 

This option allows you to retrieve a document or a selection of documents from 
the Repository. From the File menu, point to Retrieve From. There are two 
options; retrieve corporate documents or find documents as described below:  
 

Corporate Documents 
When you select the Corporate Documents option, you will view a screen 
containing the available reports. Refer to the table below for a list of all 
available reports. 
1. Select the document you want to retrieve.   
 To select more than one document, first hold down the Ctrl key and then 

select the documents. 
2. To find out more about a document first highlight the document and then 

click on the Properties button. 
• Document Tab – The document tab contains details of the title, 

subject, any keywords and comments about the report. 
• Data Provider Tab – From this tab you are able to information 

concerning the report. 
3. If you do not want to see the report immediately, remove the tick next to 

Open on Retrieval and click Retrieve, the documents would now be 
saved on your PC.  Or 

4. Click Retrieve, the document(s) will be opened by default.  
5. For further information on viewing the result of a report, see "Viewing the 

Results of a Report" on page 25. 
 
Note: If you click on the More button in the retrieve screen, you will be able 

to search for documents containing certain criteria. Refer to the 
previous section for more information about searching for documents. 
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Corporate Reports available: 
Reports in red are those reports that relate to either all media or user selected 
media types. 

The reports in black are for 'Call' information only. 

1. Account Code Log by Agent Group (All Media) 36. DDI Summary 
2. Account Code Log by Agent Group (Graphical) All Media 37. External Transferred Account Code 
3. Account Code Log by Agent Group (Graphical) 38. Incoming DDI Summary 
4. Account Code Log by Agent Group 39. Incoming Duration Summary (All Media) 
5. Account Code Log by DDI (Graphical) 40. Incoming Duration Summary 
6. Account Code Log by DDI 41. Incoming Pilot Summary 
7. Account Code Log by Pilot (Graphical) 42. Lost Call CLI 
8. Account Code Log by Pilot 43. Multi-Media Summary 
9. Account Code Log by Target (Graphical) 44. Outgoing Account Code Costing Log (All Media) 
10. Account Code Log by Target 45. Outgoing Account Code Log (All Media) 
11. Agent Activity Trace 46. Outgoing Account Code Log (Graphical) 
12. Agent Activity 47. Outgoing Account Code Log 
13. Agent Callback Request 48. Outgoing Most Common Destination by Agent Group 
14. Agent Group Busy Status 49. Pilot Call Duration 
15. Agent Group Graphical Summary (all calls) 50. Pilot Distribution by Target 
16. Agent Group Graphical Summary (All Media) 51. Pilot Distribution 
17. Agent Group Graphical Summary 52. Pilot Response 
18. AGENT Group Member Call Duration Report (all calls) 53. Pilot Routing 
19. Agent Group Member Duration (All Media) 54. Pilot Summary (all calls) 
20. Agent Group Member Duration 55. Pilot Summary 
21. Agent Group Tabular Summary (all calls) 56. System Summary 
22. Agent Group Tabular Summary 57. Target Graphical Summary (All Media) 
23. Agent Group Tabular 58. Target Graphical Summary 
24. Agent Individual (All Media) 59. Target Member Duration (All Media) 
25. Agent Individual 60. Target Member Duration 
26. Agent Tabular (All Media) 61. Transfer Call Tracking Detail by Agent 
27. Agent Tabular 62. Trunk Group Activity 
28. Customer Tracking by Call Identifier 63. Trunk Group Busy 
29. Customer Tracking by CLI 64. Trunk Group Call Duration 
30. DDI Call Duration 65. Trunk Group Response 
31. DDI Distribution by Target 66. Trunk Group Summary 
32. DDI Distribution 67. VM Call Flow Monitor by Call Flow Name 
33. DDI Response 68. VM Call Flow Monitor by Topic 
34. DDI Routing 69. VM Call Flow Monitor 
35. DDI Summary (all calls) 70. VM Summary 
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Find Documents 
When you select the Find Documents option, you are able to specify certain 
criteria when searching for documents. 

• Look for - You can look for either All Documents or just Corporate 
Documents 

• In - You can look in All Domains or just Document. 
• Where - This section allows you specify certain criteria and has been 

designed to allow you to refine your search. Listed below are the types of 
properties you can look for together with the search options. 

 

Category Search Criteria 
Comments Contains / Does Not Contain 

Data provider name Contains / Does Not Contain 

Document Has No Properties / Has Properties 

Keywords Contains / Does Not Contain 

Name Contains / Does Not Contain 

Size Is More Than / Is Equal To / Is Less Than 

Source Contains / Does Not Contain 

Subject Contains / Does Not Contain 

Submission Date After / Before (The current date and time) 

Title Contains / Does Not Contain 

Total # of categories Is More Than / Is Equal To / Is Less Than 

Total # of rows Is More Than / Is Equal To / Is Less Than 

Total Duration Is More Than / Is Equal To / Is Less Than 
 
When you have defined your search criteria, click on the Find Now button. 
Results of the search will be shown in the main window area of the screen. 
Retrieve the document as described in the section titled Corporate Documents. 
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Opening a Corporate Document 
To open a document: 
1. From the File menu, select Open. 
2. Highlight the Document. If you want to open more than one document, first 

hold down the Ctrl key and then select the required documents. 
3. Click the Open button. Once a document has been opened you can view 

the results. For more information on viewing reports, see "Viewing the 
Results of a Report" on page 25. 

 
When you have finished working on a document, close it by selecting the 
Close command from the File menu.  
Note: Only the documents that have been retrieved can be opened. Please 

refer to "Retrieve Documents" on page 20 for further information.  
 

Opening Recently used Documents. 
By default, Report Viewer keeps track of the last five documents you opened. 
You can open any of these documents quickly by selecting the name of the 
document at the bottom of the File menu. If you want Report Viewer to list 
more than four documents in the File menu, select the Options command from 
the Tools menu. In the General tab of the Options dialog box, enter the 
number of documents you want displayed by selecting the Show Recently 
Used File List option, and entering the number of files in the Entries list box. 
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Refresh Corporate Document 
When you open a report for the first time, it will contain data captured from the 
Avaya database. Refresh allows you to update the data in your report, so that 
you work with the latest data from the database. To refresh the report: 

1. From the Data menu, select Refresh Data. You can also click  on the 
toolbar). 

2. Select the time scale for the information to be shown in the selected report. 
3. Click the OK button. The screen that appears varies depending upon the 

type of report (e.g. Agent, Trunk, etc.) you have selected. 
4. Place the cursor in the relevant text boxes and enter the appropriate 

information. The Values button will be enabled when you are required to 
select information from the database, i.e. a directory number for an agent, 
trunk, etc.  

5. Click the Values button and a new screen will appear, see below. This 
screen shows the List of Values (i.e. Directory names) for the selected 
object. If this is the first time you have viewed the list of values, the query 
for the list now connects to the database in order to retrieve the values. 
This screen displays the information in either Tabular View (as above) or 
Hierarchical View. 

6. Click the Refresh button to run the query for the list of values and retrieve 
an updated result from the database. 

7. Click the required Value and then click OK. 
8. From the Enter or Select Values screen click OK.  

The status bar at the bottom of the Report Manager screen displays the 
progress/process of the Report as it is updating the information. The 
duration of updating process for each Report depends upon the Values 
that are entered.  
During the process of updating a Report, data is being fetched from the 
Archiver database. If a field can not be populated because there is no 
relevant data then a message may appear. The Query number will differ 
depending upon the type of the Report.  
 

Refreshing Agent Activity Trace Report 
This report is a special report and has to be run in the following order: 
1. Open the Agent Activity Trace Report. 

2. From the Data menu, select Refresh Data. You can also click . 
3. Fill in the prompts as follows: 
 

Field Title You enter 
AgentDN Agent's digit directory number (Can be 2,3 or 4 digits long) 

EndDate End Date as mm/dd/yy format* (e.g. 12/14/98) and Time at which 
the agent logged On 

Start Date Start Date as mm/dd/yy format* (e.g. 12/14/98) and Time at which 
the agent logged Off 

 * Date format is country dependant 
 
4. Click on the OK when you have entered the required details. 
Note: This Report does not support the List of Values option. You must type 

in the required Agent Dn field. 
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Viewing the Results of a Report 
Viewing the results of a query enables you to consult the raw, unformatted 
data that the query retrieved. 

To view the raw data of a report: 
1. Open the report. 
2. From the Data menu select View. 

3. You can also click on . The Data Manager screen appears. This screen 
shows the contents of the data providers in the current document, and 
enables you to edit or delete these. Queries enable you to retrieve data 
from a database, via a universe. 

 

Data Providers Area 
Lists all the data providers available in the Report. When you double-click a 
data provider in the list, the variables defined in this data provider are 
displayed in the list box. Select a variable from the list and you can view 
information on elements in the data provider. 
An icon identifies each type of data provider you can use: 

 – Queries on universe which consists of the following: 
 – Dimension Objects retrieve the data that will provide the basis for analysis 

in a report 
 – Measure Objects retrieve numeric data that is the result of calculations on 

data in the database. 
 

Results Tab 
The Results tab displays the raw data retrieved by a data provider selected in 
the Data Providers box. It allows you to refresh the data provider so that the 
results are up-dated from the database, and to set options that define, for 
example, how many rows are retrieved when you refresh the data. In this tab, 
you can also purge the data provider. 
The window in the Results tab displays the raw results of the selected data 
provider, organized in columns of data retrieved by each variable in the data 
provider. You can use the scroll bars and arrows to view all of the data shown 
in this window. 

• Options Button  
This opens the Query Options dialog box, which allows you to specify how 
many rows of data to retrieve when you refresh the query, and whether or 
not to include duplicate rows in the results. 

• Refresh  
Refreshes the data retrieved by the selected data provider. This ensures 
that the data you work with in the report is kept up-to-date with changes in 
the database. 

• Purge  
Deletes the results data from the Results tab window, and from the report. 
Purging the data provider keeps its components (the objects, conditions 
and sorts, for examples), but it deletes the data retrieved. You can refresh 
the data provider at any time when you want to retrieve the results again. 
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Definition Tab 
The Definition tab displays information about the data provider or the variable 
selected in the Data Providers box. If a data provider is selected, you can 
rename it, and set the date and time for automatic refreshes. If a variable is 
selected, the tab displays the variable's name, type and qualification, and lets 
you link dimensions belonging to different data providers 
Displays information about the data provider selected in the Data Providers 
box. In this tab, you can rename a data provider and set the date and time for 
automatic refreshes. 

• Name  
Displays the name of the data provider you selected. (You select a data 
provider from the list in the Data Providers box.) 

• Max Duration  
Displays the maximum length of time that this data provider can take to 
return data from the database. When the data provider is a query, the 
designer who created the universe defines this value. 

• Max Rows  
Displays the maximum number of rows that can be returned by the 
selected data provider. You can modify this value by clicking the Options 
button in the Results tab of the Data Manager dialog box. This opens the 
Query Options dialog box. 

• Refreshable  
If this attribute is editable it indicates whether you can refresh this data 
provider. 

• Universe  
Displays the name of the universe on which you built the query. To run the 
query on a different universe, click the button to the right of this field, and 
then select a universe in the Change Universe dialog box, which appears. 

• Automatic Refresh  
Select this check box if you want the data provider to be refreshed 
automatically. You can set options in this group box to define when and 
how often it will be refreshed. 
• Every n Minutes/Hours  

Select Every if you want the data provider to be refreshed automatically 
on a regular basis. You can define how often it will be refreshed. For 
example, you can enter 24 and hours, to specify every 24 hours. 

• On Date, at Time/On Date, from Time  
Select Once if you want the data provider to be refreshed automatically 
at a specific time, or after a specific time. 

• From Date (m/d/yy)  
Allows you to specify the date after which BusinessObjects will 
automatically refresh the data provider. The date format (Regional 
Settings dependant) is month/day/year, for example, 6/2/96 for June 2, 
1996. 

• Time (hh:mm:ss)  
Allows you to specify the time after which Report Viewer will 
automatically refresh the data provider. The time format is hh:mm:ss, 
for example 24:00:00 for midnight. 

• Statistics  
Displays statistical information about the data provider, that is the date, 
time, number of rows returned and the duration for each time the data 
provider was refreshed. 
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Printing Reports 
The Report Viewer provides all the standard Windows printing features. 
 

Using Page Setup 
The Page Setup command provides options relating to paper size and source, 
the orientations of the printed page and the page margins. It is highly 
recommended NOT to alter the Page Setup of the Avaya Corporate 
Documents. 
 

Using Print Preview 
Print Preview enables you to see how your Report will look like when you print 
it out. In the Print Preview Window, you can zoom in on your Report, move 
easily between the pages of the Report, as well as access the Print dialog box. 
To preview a Report before printing it, select the Print Preview command from 
the File menu, or click the Print Preview button in the toolbar. 
 

Printing 
To Print a Report, from the File menu, select Print command, or from the 

toolbar click . 
The options in Print dialog box relate to the default printer at your site, the 
range of pages to be printed and the number of copies to be printed. 
Click OK to Print the Report. 
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Reports for Scheduled Processing 
Overview 

Scheduled processing, also referred to as batch processing, means carrying 
out tasks on your reports at specified times or intervals. For example, you can 
use scheduled processing to refresh the data in a report at the same time 
every night. Scheduled processing thus enables you and your organization to 
work on reports while you are away from your computer, which saves you 
time. It also enables you to work at off peak times, which reduces traffic on the 
network. 
The Report Scheduler module is responsible for the scheduled processing of 
documents. You submit a document by sending it to Report Scheduler, which 
can perform the following tasks: 
– Refresh one, some, or all of the data providers in the document. 
– Print the reports in the document. 
– Send the processed document back to yourself and to other users or 

groups of users. 
– Save a copy of the document in Hypertext Markup Language (HTML), then 

post the document on your worldwide web server. Currently only supported 
with Explorer 5.01 or higher. 

Once you have specified the tasks you want Report Scheduler to perform, you 
can schedule them. You can carry out the tasks once at a specified time, or 
repeatedly at the same time every day, week, or month.  
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Submitting a Report 
Provided that your Access Level grants you access to Report Scheduler, you 
can submit an individual, active, Report for scheduled processing if your 
Access Level grants you access to Report Scheduler and the Report is open. If 
you are working with more than one open document when you schedule a 
report, then the active report is sent. 

To submit a report: 
1. Open the Report you want to submit. 
2. From the Data menu select the Schedule Report option. A date range 

screen appears. Enter what date parameters you want the report to include. 
When you have specified the date range click on the Ok button. 

3. You now can enter the values for the report that you have selected. The 
fields available will differ according to the report that you have selected to 
run. Use the Values button to select specific values i.e. shift start and finish 
times. Click on the Ok button when finished entering values. 

4. The Schedule Task Properties screen allows you to specify the times when 
you want the report to be produced. 
• Description – Enter a short description of the document so that when it 

is sent to the report scheduler you can clearly identify it. 
• Schedule – Highlight an entry and click Edit to change: 
 Start Date – Specify the date and time that you want Report Scheduler 

to start processing the report. 
 End Date – Specify the date and time that you want processing to stop 

(when Run set to daily, monthly, or month dates. 
 Run – This section allows you to specify when you want the report to 

be run, once, daily, monthly or month dates. Depending on your 
selection in this area the Interval area will respond accordingly. 

 Interval – Allows you to further define the period that you want the 
report to be run, e.g. day, hour and minute. 

 Distribution – A report associated with a task can be distributed to a 
printer, via email or sent to a folder on the PC.  

5. Click on the OK button when you have completed the screen. 
6. If you have successfully scheduled the report, a screen will appear 

informing you of such. 
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Trouble Shooting 
 Report Viewer 

• Agent Activity Trace Report  
When refreshing the above report, follow the instructions in "  
 
Refreshing Agent Activity Trace Report" on page 24. 

 
Nil Data in the Reports  
Graphs do not display nil (zero) data. E.g. the report below will be displayed on 
a Report Manager. 

 
This cannot be displayed on a Corporate Document (see below) 
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